1.設(shè)置主機名/系統(tǒng)名
IOS:switch(config)# hostname "hostname"
CLI:switch(enable) set system name name-string
2.設(shè)置登錄口令
IOS:switch(config)# enable password level 1 password
CLI:switch(enable) set password
switch(enable) set enalbepass
3.設(shè)置遠(yuǎn)程訪問
IOS:switch(config)# interface vlan 1
switch(config-if)# ip address ip-address netmask
switch(config-if)# ip default-gateway ip-address
CLI:switch(enable) set interface sc0 ip-address netmask broadcast-address
switch(enable) set interface sc0 vlan
switch(enable) set ip route default gateway
4.啟用和瀏覽 CDP 信息
IOS:switch(config-if)# cdp enable
switch(config-if)# no cdp enable
CLI:switch(enable) set cdp {enable|disable} module/port
5.查看 Cisco 鄰接設(shè)備的 CDP 通告
IOS:switch# show cdp interface [type modle/port]
switch# show cdp neighbors [type module/port] [detail]
CLI:switch(enable) show cdp neighbors[module/port] [vlan|duplex|capabilities|detail]
6.端口描述
IOS:switch(config-if)#description escription-string
CLI:switch(enable)set port name module/number description-string
7.設(shè)置端口速度
IOS:switch(config-if)# speed{10|100|auto}
CLI:switch(enable) set port speed moudle/number {10|100|auto}
switch(enable) set port speed moudle/number {4|16|auto}
8.設(shè)置以太網(wǎng)的鏈路模式
IOS:switch(config-if)# duplex {auto|full|half}
CLI:switch(enable) set port duplex module/number {full|half}
9.配置靜態(tài) VLAN
IOS:switch# vlan database
switch(vlan)# vlan vlan-num name vla
switch(vlan)# exit
switch# configure teriminal
switch(config)#interface interface module/number
switch(config-if)# switchport mode access
switch(config-if)# switchport access vlan vlan-num
switch(config-if)# end
CLI:switch(enable) set vlan vlan-num [name name]
switch(enable) set vlan vlan-num mod-num/port-list
10.配置 VLAN 中繼線
IOS:switch(config)# interface interface mod/port
switch(config-if)# switchport mode trunk
switch(config-if)#switchport trunk encapsulation {isl|dotlq}
switch(config-if)# switchport trunk allowed vlan remove vlan-list
switch(config-if)# switchport trunk allowed vlan add vlan-list
CLI:switch(enable)set trunk module/port [on|off|desirable|auto|nonegotiate]
Vlan-range [isl|dotlq|dotl0|lane|negotiate]
11.配置 VTP 管理域
IOS:switch# vlan database
switch(vlan)# vtp domain domain-name
CLI:switch(enable) set vtp [domain domain-name]
12.配置 VTP 模式
IOS:switch# vlan database
switch(vlan)# vtp domain domain-name
switch(vlan)# vtp {sever|cilent|transparent}
switch(vlan)# vtp password password
CLI:switch(enable) set vtp [domain domain-name]
[mode{ sever|cilent|transparent }][password password]
13.配置 VTP 版本
IOS:switch# vlan database
switch(vlan)# vtp v2-mode
CLI:switch(enable) set vtp v2 enable
14.啟動 VTP 剪裁
IOS:switch# vlan database
switch(vlan)# vtp pruning
CLI:switch(enable) set vtp pruning enable
15.配置以太信道
IOS:switch(config-if)# port group group-number [distribution {source|destination}]
CLI:switch(enable) set port channel moudle/port-range mode{on|off|desirable|auto}
16.調(diào)整根路徑成本
IOS:switch(config-if)#spanning-tree [vlan vlan-list] cost cost
CLI:switch(enable)set spantree portcost moudle/port cost
switch(enable)set spantree portvlancost moudle/port [cost cost][vlan-list]
17.調(diào)整端口 ID
IOS:switch(config-if)#spanning-tree[vlan vlan-list]port-priority port-priority
CLI:switch(enable)set spantree portpri {mldule/port}priority
switch(enable)set spantree portvlanpri {module/port}priority [vlans]
18.修改 STP 時鐘
IOS:switch(config)# spanning-tree [vlan vlan-list] hello-time seconds
switch(config)#spanning-tree [vlan vlan-list] forward-time seconds
switch(config)#spanning-tree [vlan vlan-list] max-age seconds
CLI:switch(enable) set spantree hello interval[vlan]
switch(enable) set spantree fwddelay delay [vlan]
switch(enable) set spantree maxage agingtiame[vlan]
19.啟用或禁用 Port Fast 特征
IOS:switch(config-if)#spanning-tree portfast
CLI:switch(enable)set spantree portfast {module/port}{enable|disable}
20.啟用或禁用 UplinkFast 特征
IOS:switch(config)#spanning-tree uplinkfast [max-update-rate pkts-per-second]
CLI:switch(enable)set spantree uplinkfast {enable|disable}[rate update-rate] [all-protocols
off|on]
為了將交換機配置成一個集群的命令交換機,首先要給管理接口分配一個 IP 地址,然后使用下列命令:
switch(config)# cluster enable cluster-name
21. 為了從一條中繼鏈路上刪除 VLAN,可使用下列命令:
switch(enable) clear trunk module/port vlan-range
22. 用 show vtp domain 顯示管理域的 VTP 參數(shù).
23. 用 show vtp statistics 顯示管理域的 VTP 參數(shù).
24. 在 Catalyst 交換機上定義 TrBRF 的命令如下:
switch(enable) set vlan vlan-name [name name] type trbrf bridge bridge-num[stp {ieee|ibm}]
25. 在 Catalyst 交換機上定義 TrCRF 的命令如下:
switch (enable) set vlan vlan-num [name name] type trcrf {ring hex-ring-num|decring
decimal-ring-num} parent vlan-num
26. 在創(chuàng)建好 TrBRF VLAN 之后,就可以給它分配交換機端口.對于以太網(wǎng)交換,可以采用如下命令給 VLAN
分配端口:
switch(enable) set vlan vlan-num mod-num/port-num
27. 命令 show spantree 顯示一個交換機端口的 STP 狀態(tài).
28. 配置一個 ELAN 的 LES 和 BUS,可以使用下列命令:
ATM (config)# interface atm number.subint multioint
ATM(config-subif)# lane serber-bus ethernet elan-name
29. 配置 LECS:
ATM(config)# lane database database-name
ATM(lane-config-databade)# name elan1-name server-atm-address les1-nsap-address
ATM(lane-config-databade)# name elan2-name server-atm-address les2-nsap-address
ATM(lane-config-databade)# name ...
30. 創(chuàng)建完數(shù)據(jù)庫后,必須在主接口上啟動 LECS.
命令如下: ATM(config)# interface atm number
ATM(config-if)# lane config database database-name
ATM(config-if)# lane config auto-config-atm-address
31. 將每個 LEC 配置到一個不同的 ATM 子接口上.命令如下:
ATM(config)# interface atm number.subint multipoint
ATM(config)# lane client ethernet vlan-num elan-num
32. 用 show lane server 顯示 LES 的狀態(tài).
33. 用 show lane bus 顯示 bus 的狀態(tài).
34. 用 show lane database 顯示 LECS 數(shù)據(jù)庫可內(nèi)容.
35. 用 show lane client 顯示 LEC 的狀態(tài).
36. 用 show module 顯示已安裝的模塊列表.
37. 用物理接口建立與 VLAN 的連接:
router# configure terminal
router(config)# interface media module/port
router(config-if)# description description-string
router(config-if)# ip address ip-addr subnet-mask
router(config-if)# no shutdown
38. 用中繼鏈路來建立與 VLAN 的連接:
router(config)# interface module/port.subinterface
router(config-ig)# encapsulation[isl|dotlq] vlan-number
router(config-if)# ip address ip-address subnet-mask
39. 用 LANE 來建立與 VLAN 的連接:
router(config)# interface atm module/port
router(config-if)# no ip address
router(config-if)# atm pvc 1 0 5 qsaal
router(config-if)# atm pvc 2 0 16 ilni
router(config-if)# interface atm module/port.subinterface multipoint
router(config-if)# ip address ip-address subnet-mask
router(config-if)# lane client ethernet elan-num
router(config-if)# interface atm module/port.subinterface multipoint
router(config-if)# ip address ip-address subnet-name
router(config-if)# lane client ethernet elan-name
router(config-if)# ...
40. 為了在路由處理器上進(jìn)行動態(tài)路由配置,可以用下列 IOS 命令來進(jìn)行:
router(config)# ip routing
router(config)# router ip-routing-protocol
router(config-router)# network ip-network-number
router(config-router)# network ip-network-number
41. 配置默認(rèn)路由: switch(enable) set ip route default gateway
42. 為一個路由處理器分配 VLANID,可在接口模式下使用下列命令:
router(config)# interface interface number
router(config-if)# mls rp vlan-id vlan-id-num
43. 在路由處理器啟用 MLSP: router(config)# mls rp ip
44. 為了把一個外置的路由處理器接口和交換機安置在同一個 VTP 域中:
router(config)# interface interface number
router(config-if)# mls rp vtp-domain domain-name
45. 查看指定的 VTP 域的信息: router# show mls rp vtp-domain vtp domain name
46. 要確定 RSM 或路由器上的管理接口,可以在接口模式下輸入下列命令:
router(config-if)#mls rp management-interface
47. 要檢驗 MLS-RP 的配置情況: router# show mls rp
48. 檢驗特定接口上的 MLS 配置:router# show mls rp interface interface number
49. 為了在 MLS-SE 上設(shè)置流掩碼而又不想在任一個路由處理器接口上設(shè)置訪問列表:
set mls flow [destination|destination-source|full]
50. 為使 MLS 和輸入訪問列表可以兼容,可以在全局模式下使用下列命令:
router(config)# mls rp ip input-acl
51. 當(dāng)某個交換機的第 3 層交換失效時,可在交換機的特權(quán)模式下輸入下列命令:
switch(enable) set mls enable
52. 若想改變老化時間的值,可在特權(quán)模式下輸入以下命令:
switch(enable) set mls agingtime agingtime
53. 設(shè)置快速老化:switch(enable) set mls agingtime fast fastagingtime pkt_threshold
54. 確定那些 MLS-RP 和 MLS-SE 參與了 MLS,可先顯示交換機引用列表中的內(nèi)容再確定:
switch(enable) show mls include
55. 顯示 MLS 高速緩存記錄: switch(enable) show mls entry
56. 用命令 show in arp 顯示 ARP 高速緩存區(qū)的內(nèi)容。
57. 要把路由器配置為 HSRP 備份組的成員,可以在接口配置模式下使用下面的命令:
router(config-if)# standby group-number ip ip-address
58. 為了使一個路由器重新恢復(fù)轉(zhuǎn)發(fā)路由器的角色,在接口配置模式下:
router(config-if)# standy group-number preempt
59. 訪問時間和保持時間參數(shù)是可配置的:
router(config-if)# standy group-number timers hellotime holdtime
60. 配置 HSRP 跟蹤:router(config-if)# standy group-number track type-number interface-priority
61. 要顯示 HSRP 路由器的狀態(tài):router# show standby type-number group brief
62. 用命令 show ip igmp 確定當(dāng)選的查詢器。
63. 啟動 IP 組播路由選擇:router(config)# ip muticast-routing
64. 啟動接口上的PIM: dalllasr1>(config-if)# ip pim {dense-mode|sparse-mode|sparse-dense-mode}
65. 啟動稀疏-稠密模式下的 PIM:
router# ip multicast-routing
router# interface type number
router# ip pim sparse-dense-mode
66. 核實 PIM 的配置: dallasr1># show ip pim interface[type number] [count]
67. 顯示 PIM 鄰居: dallasr1># show ip neighbor type number
68. 為了配置 RP 的地址,命令如下:
dallasr1># ip pim rp-address ip-address [group-access-list-number][override]
69. 選擇一個默認(rèn)的 RP: dallasr1># ip pim rp-address
通告 RP 和它所服務(wù)的組范圍:
dallasr1># ip pim send-rp-announce type number scope ttl group-list access-list-number
為管理范圍組通告 RP 的地址:
dallasr1># ip pim send-rp-announce ethernet0 scope 16 group-list1
dallasr1># access-list 1 permit 266.0.0.0 0.255.255.255
設(shè)定一個 RP 映像代理:dallasr1># ip pim send-rp-discovery scope ttl
核實組到 RP 的映像:
dallasr1># show ip pim rp mApping
dallasr1># show ip pim rp [group-name|group-address] [mapping]
70. 在路由器接口上用命令 ip multicast ttl-threshold ttl-value 設(shè)定 TTL 閥值:
dallasr1>(config-if)# ip multicast ttl-threshold ttl-value
71. 用 show ip pim neighbor 顯示 PIM 鄰居表。
72. 顯示組播通信路由表中的各條記錄:
dallasr1>show ip mroute [group-name|group-address][scoure][summary][count][active kbps]
73. 要記錄一個路由器接受和發(fā)送的全部 IP 組播包:
dallasr1> #debug ip mpacket [detail] [access-list][group]
74. 要在 CISCO 路由器上配置 CGMP: dallasr1>(config-if)# ip cgmp
75.配置一個組播路由器,使之加入某一個特定的組播組:
dallasr1>(config-if)# ip igmp join-group group-address
76. 關(guān)閉 CGMP: dallasr1>(config-if)# no ip cgmp
77. 啟動交換機上的 CGMP: dallasr1>(enable) set cgmp enable
78. 核實 Catalyst 交換機上 CGMP 的配置情況:
catalystla1>(enable) show config
set prompt catalystla1>
set interface sc0 192.168.1.1 255.255.255.0
set cgmp enable
79. CGMP 離開的設(shè)置: Dallas_SW(enable) set cgmp leave
80. 在 Cisco 設(shè)備上修改控制端口密碼:
R1(config)# line console 0
R1(config-line)# login
R1(config-line)# password Lisbon
R1(config)# enable password Lilbao
R1(config)# login local
R1(config)# username student password cisco
81. 在 Cisco 設(shè)備上設(shè)置控制臺及 vty 端口的會話超時:
R1(config)# line console 0
R1(config-line)# exec-timeout 5 10
R1(config)# line vty 0 4
R1(config-line)# exec-timeout 5 2
82. 在 Cisco 設(shè)備上設(shè)定特權(quán)級:
R1(config)# privilege configure level 3 username
R1(config)# privilege configure level 3 copy run start
R1(config)# privilege configure level 3 ping
R1(config)# privilege configure level 3 show run
R1(config)# enable secret level 3 cisco
83. 使用命令 privilege 可定義在該特權(quán)級下使用的命令:
router(config)# privilege mode level level command
84. 設(shè)定用戶特權(quán)級:
router(config)# enable secret level 3 dallas
router(config)# enable secret san-fran
router(config)# username student password cisco
85. 標(biāo)志設(shè)置與顯示:
R1(config)# banner motd ‘unauthorized access will be prosecuted!'
86. 設(shè)置 vty 訪問:
R1(config)# access-list 1 permit 192.168.2.5
R1(config)# line vty 0 4
R1(config)# access-class 1 in
87. 配置 HTTP 訪問:
Router3(config)# access-list 1 permit 192.168.10.7
Router3(config)# ip http sever
Router3(config)# ip http access-class 1
Router3(config)# ip http authentication local
Router3(config)# username student password cisco
88. 要啟用 HTTP 訪問,請鍵入以下命令: switch(config)# ip http sever
89. 在基于 set 命令的交換機上用 setCL1 啟動和核實端口安全:
switch(enable) set port security mod_num/port_num...enable mac address
switch(enable) show port mod_num/port_num
在基于 CiscoIOS 命令的交換機上啟動和核實端口安全:
switch(config-if)# port secure [mac-mac-count maximum-MAC-count]
switch# show mac-address-table security [type module/port]
90. 用命令 access-list 在標(biāo)準(zhǔn)通信量過濾表中創(chuàng)建一條記錄:
Router(config)# access-list access-list-number {permit|deny} source-address
[source-address]
91. 用命令 access-list 在擴展通信量過濾表中創(chuàng)建一條記錄:
Router(config)#access-list access-list-number
{permit|deny{protocol|protocol-keyword}}{source source-wildcard|any}{destination
destination-wildcard|any}[protocol-specific options][log]
92. 對于帶內(nèi)路由更新,配置路由更新的最基本的命令格式是:
R1(config-router)#distribute-list access-list-number|name in [type number]
93. 對于帶外路由更新,配置路由更新的最基本的命令格式是:
R1(config-router)#distribute-list access-list-number|name out [interface-name]
routing-process| autonomous-system-number
94. set snmp 命令選項:
set snmp community {read-only|ready-write|read-write-all}[community_string]
95. set snmp trap 命令格式如下:
set snmp trap {enable|disable} [all|moudle|classis|bridge|repeater|
auth|vtp|ippermit|vmps|config|entity|stpx]
set snmp trap rvcr_addr rcvr_community
96. 啟用 SNMP chassis 陷阱: Console>(enable) set snmp trap enable chassis
97. 啟用所有 SNMP chassis 陷阱: Console>(enable) set snmp trap enable
98. 禁用 SNMP chassis 陷阱: Console>(enable) set snmp trap disable chassis
99. 給 SNMP 陷阱接收表加一條記錄: Console>(enable) set snmp trap 192.122.173.42 public
100. show snmp 輸出結(jié)果。
101. 命令 set snmp rmon enable 的輸出結(jié)果。
102. 顯示 SPAN 信息:Consile> show span